Bug #1324

crash in GeometryPlotter using EquationColumn

Added by Andy Dufilie over 3 years ago. Updated over 3 years ago.

Status:ResolvedStart date:07/17/2013
Priority:NormalDue date:
Assignee:John Fallon% Done:

0%

Category:-
Target version:-
Complexity: OIC Priority:No
Required by:

Description

Reproducible here:
http://demo.oicweave.org/weave.html?file=test-crash-GeometryPlotter.weave

TypeError: Error #1034: Type Coercion failed: cannot convert "geom.getValueFromKey(" to weave.primitives.GeneralizedGeometry.
    at weave.visualization.plotters::GeometryPlotter/getDataBoundsFromRecordKey()
    at weave.utils::SpatialIndex/_iterate1()
    at Function/<anonymous>()
    at Function/http://adobe.com/AS3/2006/builtin::call()
    at weave.core::StageUtils/_iterateTask()
    at Function/http://adobe.com/AS3/2006/builtin::apply()
    at weave.core::StageUtils/handleCallLater()
    at weave.core::StageUtils/handleEnterFrame()
    at Function/http://adobe.com/AS3/2006/builtin::apply()
    at weave.core::CallbackCollection/_runCallbacksImmediately()
    at weave.core::CallbackCollection/triggerCallbacks()
    at Function/<anonymous>()
    at Function/<anonymous>()

Weave_2013-07-17_19.34.00.weave (159 KB) Andy Dufilie, 07/17/2013 07:45 PM

History

#1 Updated by Andy Dufilie over 3 years ago

  • Description updated (diff)

#2 Updated by John Fallon over 3 years ago

The problem is that the equation in the Equation column changed from geom.getValueFromKey(getKey(fkey)) to geom.getValueFromKey(',mgetKey(fkey)). What changes did you make to Weave between those two session states?

#3 Updated by Andy Dufilie over 3 years ago

It doesn't matter. The point is it should never crash, meaning appropriate error checking should be added.

#4 Updated by Andy Dufilie over 3 years ago

  • Description updated (diff)

#5 Updated by Andy Dufilie over 3 years ago

  • Description updated (diff)

#6 Updated by John Fallon over 3 years ago

  • Assignee set to John Fallon

#7 Updated by John Fallon over 3 years ago

  • Status changed from Open to Resolved

Also available in: Atom PDF