Bug #220

WFS map projection persistence

Added by Daniel Eisenberg over 5 years ago. Updated over 5 years ago.

Status:ResolvedStart date:07/14/2011
Priority:NormalDue date:
Assignee:Kyle Monico% Done:

100%

Category:Visualization InterfaceEstimated time:0.25 h
Target version:1.0
Complexity: OIC Priority:
Required by:

Description

As I understand it, the map projections specified (EPSG:3735 for our OH South) does not persist with the saved session state.

I’ve noticed from previous discussions that projections were supposed to be entered into both the map interface and the Admin Console.

WFS maps, however, do not have anything in the Admin Console and can only be projected on the fly. Is there a way to keep the reprojected value as the default? We don't expect our users to know about projections.

Scrnshot1.GIF - Screenshot of WFS map - reprojected. Saved session state (114 KB) Daniel Eisenberg, 07/14/2011 02:55 PM

Scrnshot2.GIF - Screenshot of WFS map - after user views url (129 KB) Daniel Eisenberg, 07/14/2011 02:55 PM

History

#1 Updated by Andy Dufilie over 5 years ago

  • Status changed from Open to Awaiting Feedback
  • Assignee deleted (Daniel Eisenberg)

Please explain what you mean by "does not persist with the saved session state".
Also, what do you mean by "reprojected value?"
Perhaps a screenshot would clarify?

#2 Updated by Daniel Eisenberg over 5 years ago

I was referring to this:
When I set up a map using WFS, I can reproject it on the fly using the projection input field of the drop-down menu under the “advanced” tab of the map tool (great addition by the way!).

Then I save my session state as always. I can send the url to somebody to view. Also great.

But the reprojected value does not “stick” (which is what I meant by “persist.”) Every other part of the map is as I set it prior to saving the session state. The person I send the url to can view the map as I set it up except that it uses the projection as specified by the WFS service rather than the reprojected EPSG index (the EPSG:3735, what I meant by value). Nor does the new EPSG appear in the drop-down menu.

I realize this is not a bug, which is why I added it to the feature requests. I was hoping for a new feature that A: holds the reprojection EPSG index in the drop down menu when the session state is saved and B: looks for that when drawing the map when a user visits, rather than defaulting to the WGS projection. I know this differs from the way that shapefiles are handled, but as there is no Admin Console tab for WFS, we cannot put the projection for the map there.

I’m not sure if screenshots will really help but Scrnshot1.gif is the saved session with the reprojection. Scrnshot2.gif is what happens if you place the following url into your browser (which is the same as the saved session state). You can see how the map looks "stretched wide" in Scrnshot2.
[[http://openindicators:8100/weave.html?defaults=wfs_7-14-2011G.xml]]

I hope that clears it up more.

#3 Updated by Kyle Monico over 5 years ago

  • Status changed from Awaiting Feedback to In Progress
  • Assignee set to Kyle Monico
  • Estimated time set to 2.00

It's a bug. I'll fix it tomorrow at the latest.

#4 Updated by Kyle Monico over 5 years ago

  • Status changed from In Progress to Resolved
  • % Done changed from 0 to 100
  • Estimated time changed from 2.00 to 0.25

And it's fixed.

#5 Updated by Andy Dufilie over 5 years ago

  • Tracker changed from Feature to Bug

#6 Updated by Andy Dufilie over 5 years ago

  • Target version set to 1.0

Also available in: Atom PDF