Feature #395

Create a new binning definition defined by a list of comma separated strings (Color binning for text values)

Added by Rebecca Lee over 5 years ago. Updated over 5 years ago.

Status:ResolvedStart date:08/17/2011
Priority:NormalDue date:
Assignee:-% Done:

100%

Category:Internal Code Refactoring
Target version:1.0
Complexity:Low OIC Priority:
Required by:ProvPlan, Providence, RI

Description

The user can choose an attribute for coloring that has text values, and set up the bins according to the text value. I would imagine it would work like the Custom Split, but without the min/max. The user would enter a comma separated string of the text values they wanted as bins.


Subtasks


Related issues

Related to Weave - Feature #19: Create a new binning definition that uses nice numbers Open 06/15/2011
Related to Weave - Bug #308: CustomSplitBinningDefinition does not bin records correctly. Resolved 08/05/2011

History

#1 Updated by Rebecca Lee over 5 years ago

Sorry, this should be a feature request, not a bug. I don't see where to edit that.

#2 Updated by Andy Dufilie over 5 years ago

  • Tracker changed from Bug to Feature

There's a tiny link at the top of the "Update" box that says (More). You can change the tracker there.

#3 Updated by Andy Dufilie over 5 years ago

  • Subject changed from Color binning for text values to Create a new binning definition defined by a list of comma separated strings (Color binning for text values)

#4 Updated by Andy Dufilie over 5 years ago

  • Category set to Internal Code Refactoring
  • Complexity set to Low

#5 Updated by Andy Dufilie over 5 years ago

There is a new binning definition that creates one bin for every unique string value. Is that sufficient, or do you still need to explicitly list the strings?

#6 Updated by Andy Dufilie over 5 years ago

  • Status changed from Open to Awaiting Feedback
  • Required by set to ProvPlan, Providence, RI

#7 Updated by Rebecca Lee over 5 years ago

Is there somewhere I can test the current implementation? We haven't downloaded a nightly in awhile and won't be able to until later this week.

#8 Updated by Andy Dufilie over 5 years ago

http://demo.oicweave.org:8080/weave.html?file=obesity.xml

Just open the color controller, color by state name, and select the new binning def.

#9 Updated by Rebecca Lee over 5 years ago

I think this will work - will revisit later with more complicated feature request if absolutely necessary. Thanks!

#10 Updated by Andy Dufilie over 5 years ago

  • Status changed from Awaiting Feedback to Resolved

#11 Updated by Andy Dufilie over 5 years ago

  • Target version set to 1.0

Also available in: Atom PDF